玉兔远程控制0.1.0-bate14

作者: 康林 kl222.nosp@m.@126.nosp@m..com

:us: English

简介

截屏

多样式

项目位置

功能

支持操作系统

支持多语言

支持协议

远程控制协议

网络协议

功能列表

插件

状态

捐赠

贡献

下载

开发

编译

为 Linux 编译

为 Windows 编译

许可协议

简介

**玉兔远程控制**是一个开源、跨平台、支持多协议的远程控制软件。

能让你在**任何地方**使用**任何设备和系统**通过**任意方式**远程管理**任意设备和系统**。

它的目标是简单、方便、易用、安全、提高工作效率。

它包括远程桌面、远程控制、文件传输(FTP、SFTP)、终端、远程终端(SSH、TELNET)、播放器、网络工具等功能。

截屏

主窗口 最近列表窗口 连接窗口 工作窗口

多样式

默认样式 黑绿样式 黑色样式 白色样式

视频

https://github.com/user-attachments/assets/9ebdc7e6-ed7a-4813-afcf-7a04cd6f889b

项目位置

主库:https://github.com/KangLin/RabbitRemoteControl

镜像:

中国镜像:https://gitee.com/kl222/RabbitRemoteControl

sourceforge: https://sourceforge.net/projects/rabbitremotecontrol

gitlab: https://gitlab.com/kl222/RabbitRemoteControl

launchpad: https://launchpad.net/rabbitremotecontrol

bitbucket: https://bitbucket.org/kl222/rabbitremotecontrol

功能

支持操作系统

Windows 7 SP1 及以后

Unix/Linux

Android

macOS

详见:Qt5 支持平台、 Qt6 支持平台。

因为本人没有 mac 设备,所以没有做编译与测试。请有设备的朋友自行测试。 欢迎有兴趣,有能力的朋友参与项目的开发。

如果你想为.nosp@m.本人捐赠.nosp@m.开发设备,.nosp@m.请联系:.nosp@m.kl222.nosp@m.@126.nosp@m..com

远程桌面

Windows Unix/Linux Android macOS

vnc ✓ ✓ ✓ ✓

RDP ✓ ✓ ✓ ✓

Spice

Scrcpy

终端

Windows Unix/Linux Android macOS

终端 ✓ ✓ ✓

SSH ✓ ✓ ✓

TELNET ✓ ✓

串口 ✓ ✓ ✓

文件传输

Windows Unix/Linux Android macOS

FTP …… …… …… ……

SFTP …… …… …… ……

工具

Windows Unix/Linux Android macOS

播放器 ✓ ✓ ✓ ✓

局域网唤醒主机 ✓ ✓ ❌ ✓

截屏 ✓ ✓ ❌ ✓

网页浏览器 ✓ ✓ ❌ ✓

图例:

✓ : 完成; …… : 正在工作; ⭕ : 未完成; 空:未开始; ❌: 不支持

支持多语言

英语

中文

简体中文

繁体中文

支持协议

远程控制协议

VNC(虚拟网络计算)也叫 RFB(远程帧缓存): https://github.com/rfbproto/rfbproto

RDP(远程桌面协议): https://github.com/FreeRDP/FreeRDP/wiki/Reference-Documentation

Spice: https://www.spice-space.org/

终端

SSH: https://www.rfc-editor.org/info/rfc4251

libssh

TELNET: https://www.rfc-editor.org/info/rfc318

scrcpy: https://github.com/Genymobile/scrcpy

FTP(文件传输协议): https://www.rfc-editor.org/info/rfc959

SFTP(安全 Shell 文件传输协议):https://tools.ietf.org/html/draft-ietf-secsh-filexfer-02

网络协议

端到端(P2P)协议

ICE(交互式连接建立): RFC 8445

STUN: RFC 5389

TURN(在 NAT 周围使用中继进行遍历): RFC 5766

代理

[x] socks

[ ] http

[x] 端到端(P2P)代理协议: https://github.com/KangLin/RabbitRemoteControl/issues/7

功能列表

服务器 客户端 远程桌面 剪切板 文件传输 音频传输 资源重定向 P2P 代理 终端

RDP ✓ ✓ ✓ ✓ …… ✓ …… ✓ ❌

RFB …… ✓ ✓ ✓ ❌ ❌ ✓ ✓

Spice ❌

Scrcpy ❌

终端 ✓ ❌ ✓ ❌ ❌ ❌

TELNET ✓ ❌ ✓ ❌ ❌ ❌

SSH ✓ ❌ ✓ ❌ ❌

串口 ✓ ❌ ❌ ❌

FTP ✓ …… ❌ …… ❌ ❌

SFTP …… ❌ …… ❌ ❌

图例:

✓ : 完成; …… : 正在工作; ⭕ : 未完成; 空:未开始; ❌: 不支持

代理 P2P

RabbitVNC ✓ ✓

TigerVNC ✓ ✓

LibVNC

FreeRDP ……

图例:

✓ : 完成; …… : 正在工作; ⭕ : 未完成; 空:未开始; ❌: 不支持

插件

FreeRDP

VNC

RabbitVNC

TigerVnc

LibVNCServer

局域网唤醒

播放器

屏幕捕获:示例

终端

本地终端

SSH

TELNET

串口

文件传输

Ftp 服务

网页浏览器

状态

点赞数

编译状态

master 分支 develop 分支

捐赠

本软件如果对你有用,或者你喜欢它,请你捐赠,支持作者。谢谢!

如果不能显示,请打开:

https://gitlab.com/kl222/RabbitCommon/-/raw/master/Src/Resource/image/Contribute_zh_CN.png

https://sourceforge.net/p/rabbitcommon/code/ci/master/tree/Src/Resource/image/Contribute_zh_CN.png

联系:

kl222.nosp@m.@126.nosp@m..com

jami: eddacfd6c7b70b258e511e812ffab7d3490396fa

贡献

问题

讨论

邮件列表

开发组 rabbi.nosp@m.trem.nosp@m.oteco.nosp@m.ntro.nosp@m.l-dev.nosp@m.elop.nosp@m.er@li.nosp@m.sts..nosp@m.sourc.nosp@m.efor.nosp@m.ge.ne.nosp@m.t

讨论组 rabbi.nosp@m.trem.nosp@m.oteco.nosp@m.ntro.nosp@m.l-dis.nosp@m.cuss.nosp@m.@list.nosp@m.s.so.nosp@m.urcef.nosp@m.orge.nosp@m..net

贡献者: 感谢贡献者

维护打包

Linux

Debian: 需要维护官方包

rpm: 需要维护官方包

AppImage

Snap: https://snapcraft.io/rabbitremotecontrol

Flatpak: https://github.com/flathub/io.github.KangLin.RabbitRemoteControl

Windows

Windows 应用商店: 需要维护官方包

Macos: 需要维护官方包

Android: 需要维护官方包

下载

修改日志

版本号说明: https://semver.org/lang/zh-CN/

用户手册

发行版本:

开发

在线开发文档

sourceforge

github.io

编译

为 Linux 编译

为 Windows 编译

为 macOS 编译 (English)

为 Android 编译

License.md

请遵守本项目License.md和依赖库的许可协议,并感谢依赖库和工具的作者。